System.Exception: Fehler beim Erstellen des Webproxys, der im Konfigurationsabschnitt system.net/defaultproxy angegeben ist.

Der Fehler tritt in Verbindung mit Windows Version: 1803 auf und hat primär nichts mit einem Problem in unserer Software zu tun als vielmehr die Systemanforderung SMB seitens Windows.

Das Problem bzw. der Fehler tritt auf wenn die Software (z.B. ci-oof.exe) von einem Netzlaufwerk direkt gestartet wird. Beim verwenden der CI-OOF-Task.vbs (es wird lokal kopiert) ist der Anmeldevorgang erfolgreich.

Auch kopieren des OOF-Ordners (für Testzwecke) auf ein lokales Laufwerk lässt eine erfolgreiche Anmeldung zu.

 

Hier ein direkter Link zur Microsoft Knowledge Base:

https://support.microsoft.com/de-de/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

 

Sofern Sie andere Server-Versionen verwenden suchen Sie diese entsprechend heraus.

Auszug:

SMB v1 auf dem SMB-Server

Erkennen:

Get-SmbServerConfiguration | Select EnableSMB1Protocol

Deaktivieren:

Set-SmbServerConfiguration -EnableSMB1Protocol $false

Aktivieren:

Set-SmbServerConfiguration -EnableSMB1Protocol $true

Weitere Informationen finden Sie unter Serverspeicher von Microsoft.

SMB v2/v3 auf dem SMB-Server

Erkennen:

Get-SmbServerConfiguration | Select EnableSMB2Protocol

Deaktivieren:

Set-SmbServerConfiguration -EnableSMB2Protocol $false

Aktivieren:

Set-SmbServerConfiguration -EnableSMB2Protocol $true

 

Es kann ein Server-Neustart erforderlich sein.

Deutsch

Kommentare

Heißt das jetzt SMB soll in einer bestimmten Version (de)aktiviert werden? wenn ja, in welcher?

Es müssen beide aktiviert sein.

Danke für die schnelle Antwort. Verstehe. Kann das auch auf einem NAS funktionieren oder muss es ein Windows server sein?

Die Software kann liegen wo Sie diese haben möchten. Es geht nur darum, das der Server ja verwendet wird um die Anfrage weiterzuleiten.

Neuen Kommentar schreiben

Das könnte Sie auch interessieren

HTML E-Mails kommen beim Empfänger als Plain-Text an

In letzter Zeit häufen sich die Fälle in denen uns Kunden berichten, dass als HTML abgesendete E-Mails beim Empfänger als Plain-Text ankommen. Dabei geht jegliche Formatierung verloren und Grafiken aus der Signatur werden als Anlagen angefügt. Die Ursache dafür ist meistens die...

Fehlerhafte Darstellung von Listensymbolen seitens Exchange / Outlook / OWA.

In den letzten Tagen erreichen uns vermehrt Anfragen bzgl. Listensymbolen und deren Darstellung nach dem Versand. Im Screenshot wird die gleiche E-Mail einmal mit Outlook, einmal mit OWA dargestellt. Das Problem ist auch ohne Veränderung serverseitig nachvollziehbar und somit...

Exchange Warteschlange voll aufgrund von "Acknowledgement delay"

In Verbindung mit CI-Mail-Policy und "Acknowledgement delay" (ab Exchange 2010) kann es zu vollen Warteschlangen / Mail-Queues kommen. Mit Exchange 2010 wurde die sog. Shadow-Redundanz eingeführt. Diese verzögert das Löschen einer Nachricht aus den...